HomePhabricator

config: rename allow_push to allow-push

Authored by markand.

Description

config: rename allow_push to allow-push

As part of ConfigConsolidationPlan [1], rename the option according to
the new UI guidelines [2] and add an alias for backward compatibility.

[1]: https://www.mercurial-scm.org/wiki/ConfigConsolidationPlan
[2]: https://www.mercurial-scm.org/wiki/UIGuideline#adding_new_options

Details

Committed
markandOct 19 2017, 5:46 AM
Parents
rHGda5d5ea7d696: config: rename allowpull to allow-pull
Branches
Unknown
Tags
Unknown