HomePhabricator

upgrade: support running upgrade if repository has share-safe requirement

Authored by pulkit.

Description

upgrade: support running upgrade if repository has share-safe requirement

This helps us in testing changing requirements of source repository and checking
that the shared repository works.

Differential Revision: https://phab.mercurial-scm.org/D8660