HomePhabricator

setup: raise minimum Python version to 2.7.4

Description

setup: raise minimum Python version to 2.7.4

On older Python versions, Mercurial is not really usable because of
https://bugs.python.org/issue10211.

Recently someone reported a crash on the mailing list when running Mercurial
on Python 2.7.3. There was consensus that fixing compatibility for a Python
version more than 7 years old is not worth it. So, instead of making Mercurial
crash with an obscure exception, this patch raises the minimum Python version
to 2.7.4.

Details