remotefilelog: avoid temporarily using "count" variable as synonym for "total"
The "count" variable is generally used for updating progress, but
early in fileserverclient.request(), its used to mean the total
count. We already have another "total" variable for that, so it seems
much clearer to use that.
Differential Revision: https://phab.mercurial-scm.org/D5382