HomePhabricator

commitctx: treat `filesadded` more like `filesremoved`

Authored by marmoute.

Description

commitctx: treat filesadded more like filesremoved

Accumulating the filename in a list will have a negligible cost and deal with
the list of added files like the other ones will make is code cleaning simpler.
The two variable with very close name is not great, but my plan is to split most
of the code in a separated function which will make the "problem" go away by
itself.

Details

Committed
marmouteJul 23 2020, 5:08 PM
Parents
rHG595307e14140: commitctx: move `writechangesetcopy` business at the end a code section
Branches
Unknown
Tags
Unknown