Page MenuHomePhabricator

revlog: rename revlog I/O classes to reflect version (API)
Needs RevisionPublic

Authored by indygreg on Jan 10 2019, 7:32 PM.

Details

Reviewers
baymax
Group Reviewers
hg-reviewers
Summary

I never liked these names. They imply the existence of exactly
2 revlog versions. We're hacking on version 2. So let's
introduce better names.

Diff Detail

Repository
rHG Mercurial
Lint
Lint Skipped
Unit
Unit Tests Skipped

Event Timeline

indygreg created this revision.Jan 10 2019, 7:32 PM
baymax requested changes to this revision.Jan 24 2020, 12:32 PM

There seems to have been no activities on this Diff for the past 3 Months.

By policy, we are automatically moving it out of the need-review state.

Please, move it back to need-review without hesitation if this diff should still be discussed.

:baymax:need-review-idle:

This revision now requires changes to proceed.Jan 24 2020, 12:32 PM