sparse: don't enable on clone if it was a narrow clone
ClosedPublic

Authored by pulkit on Dec 24 2018, 8:18 AM.

Details

Summary

When both sparse and narrow extensions are enabled and we do a narrow clone,
sparse enables itself because it reads --include flag and thinks that user is
trying to do a sparse clone.

This patch changes that behavior, and now if both extensions are enabled and
user passes --narrow, then the includes and excludes won't be considered as
part of sparse profile.

Diff Detail

Repository
rHG Mercurial
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
pulkit created this revision.Dec 24 2018, 8:18 AM
This revision was automatically updated to reflect the committed changes.