Page MenuHomePhabricator

branchcache: rename itervalues() to iterheads()
ClosedPublic

Authored by pulkit on Mar 19 2019, 7:30 AM.

Details

Summary

The itervalues() exists because branchcache() had a dict interface. Since it no
longer has a dict interface, it makes sense to have better function names.

If a person does not understand how branchcache stores info, it will be hard for
them to guess what itervalues() does.

Diff Detail

Repository
rHG Mercurial
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

pulkit created this revision.Mar 19 2019, 7:30 AM
This revision was automatically updated to reflect the committed changes.