Page MenuHomePhabricator

inno: drop support for Windows 95/98/ME
ClosedPublic

Authored by mharbison72 on Dec 18 2019, 12:49 AM.

Diff Detail

Repository
rHG Mercurial
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

mharbison72 created this revision.Dec 18 2019, 12:49 AM
pulkit accepted this revision.Dec 18 2019, 12:53 AM
This revision is now accepted and ready to land.Dec 18 2019, 12:53 AM

I'm not at all familiar with this installer, though the changes seem straight forward. When I went to build it though, it seems like the Inno installer is currently broke:

\> py -3 contrib\packaging\packaging.py inno --python C:\Python27\python.exe
...
Collecting configparser>=3.5; python_version == "2.7"
ERROR: In --require-hashes mode, all requirements must have their versions pinned with ==. These do not:
    configparser>=3.5; python_version == "2.7" from https://files.pythonhosted.org/packages/7a/2a/95ed0501cf5d8709490b1d3a3f9b5cf340da6c433f896bbe9ce08dbe6785/configparser-4.0.2-py2.py3-none-any.whl#sha256=254c1d9c79f60c45dfde850850883d5aaa7f19a23f13561243a050d5a7c3fe4c (from entrypoints==0.3->-r C:\Users\Matt\hg\contrib\packaging\inno\requirements.txt (line 25))

I see that there is a configparser version pinned in linux-requirements-py2.txt, but that's an autogenerated file. I was able to build the Wix installer a couple of weeks ago.

CC: @indygreg

This revision was automatically updated to reflect the committed changes.