This is passed often as a long tuple that is not easy to know the form of, so
we refactor everything in this struct.
This also renames wdir_tracked to follow the Python wc_tracked, even though
the on-disk format uses WDIR_TRACKED.
I think a single naming scheme is better, but we can't easily break the Python
impl now because of extensions, so this is low-effort enough and facilitates