Read the content of a revlog at a given revision.
- Group Reviewers
- rHGb56df13a0450: hg-core: define a `DebugData` `Operation`
This enum duplicates a lot of states from RevlogError. This kinda feels like an anti-pattern. Should it store a RevlogError(RevlogError) instead?
(I legitimately do not know what the best practice is here. Completely duplicating an enum just doesn't sit right with me!)
We would ideally have a method on the repo resolve this path, since the logic is influenced by .hg/requires. But this is probably fine for now.