Page MenuHomePhabricator

convert-bazaar: use breezy package instead of old bzr one
ClosedPublic

Authored by Alphare on Apr 26 2021, 5:03 PM.

Details

Summary

Breezy is the most recent of the two, and works on Python 3 while being
compatible with the (old) Bazaar file format.

This patch contains a variety of unicode <-> bytes changes, API breakage fixing,
restoring failing imports and changing the executable from bzr to brz.

I recommend using the debian packages for brz and python3-breezy (3.1+),
because the pip package seems to be haunted by radioactive dragons.

Diff Detail

Repository
rHG Mercurial
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

Alphare created this revision.Apr 26 2021, 5:03 PM
Alphare planned changes to this revision.Apr 26 2021, 5:30 PM

I broke something, sorry for the noise.

baymax updated this revision to Diff 27164.Apr 27 2021, 12:03 PM

โœ… refresh by Heptapod after a successful CI run (๐Ÿ™ ๐Ÿ’š)
โš  This patch is intended for stable โš 

Just to be clear, this is now good to review.

durin42 requested changes to this revision.May 6 2021, 3:17 PM
durin42 added a subscriber: durin42.

I'm getting conflicts in the hghave part, but otherwise LGTM

This revision now requires changes to proceed.May 6 2021, 3:17 PM
Alphare updated this revision to Diff 28428.Jun 3 2021, 4:44 AM
pulkit accepted this revision.Jun 4 2021, 6:00 AM
This revision was not accepted when it landed; it landed in state Needs Review.
This revision was automatically updated to reflect the committed changes.