This is more consistent.
- Group Reviewers
- rHG76c071bba40d: bookmarks: add support for `mirror` mode to `incoming`
I find the single line version of these functions much easier to read.
Nit: use set(localmarks) instead of set(repo._bookmarks)?
Also, perhaps I'm less familiar with idiomatic python and this isn't confusing for others, but would it make sense to explicitly use .keys() (so we have allmarks = set(remotemarks.keys()) | set(localmarks.keys())? It would have likely avoided a small amount of confusion I had a few lines below.