uncommit: convert _fixdirstate() into _movedirstate()
ClosedPublic

Authored by martinvonz on Mon, Mar 11, 2:19 PM.

Details

Summary

_fixdirstate() already also updates to the given commit, so let's
rename it to _movedirstate(). Also update the documentation and drop
the unnecessary "curctx" argument, since that should always be
repo['.'].

Diff Detail

Repository
rHG Mercurial
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
martinvonz created this revision.Mon, Mar 11, 2:19 PM

In the documentation part don't you think there should be information about the matcher as there was before D971

In the documentation part don't you think there should be information about the matcher as there was before D971

Yeah, we should document that. I'll send another patch.

pulkit accepted this revision.Mon, Mar 11, 6:39 PM
This revision was automatically updated to reflect the committed changes.