Page MenuHomePhabricator

debugstrip: add debugstrip to core
Needs ReviewPublic

Authored by navaneeth.suresh on Sat, Oct 5, 3:41 PM.

Details

Reviewers
durin42
Group Reviewers
hg-reviewers
Summary

Until now, strip was bootstrapped as an extension. This patch adds
debugstrip on core. For the users who are still used to strip
extension, we will preserve that name.

Diff Detail

Repository
rHG Mercurial
Lint
Lint Skipped
Unit
Unit Tests Skipped

Event Timeline

durin42 requested changes to this revision.Sat, Oct 5, 3:55 PM
durin42 added inline comments.
mercurial/commands.py
5646 ↗(On Diff #16856)

debugstrip please (and put it in debugcommands)

and Gregory points out we need a strip extension that preserves the old strip name for users that are used to that

This revision now requires changes to proceed.Sat, Oct 5, 3:55 PM
mercurial/commands.py
5646 ↗(On Diff #16856)

i see. do i need to replace strip by debugstrip on every occurrence in tests? otherwise, i would have to revert the changes in the tests and keep the extension as it is.

durin42 added inline comments.Sat, Oct 5, 5:02 PM
mercurial/commands.py
5646 ↗(On Diff #16856)

One or two is fine, you can leave the majority on the legacy extension flavor. We want some using each so we don't have to add a new test to test one of them.

navaneeth.suresh retitled this revision from strip: move strip extension to core to strip: move strip extension to core as debugstrip.Sun, Oct 6, 1:48 PM
navaneeth.suresh edited the summary of this revision. (Show Details)
navaneeth.suresh updated this revision to Diff 16914.
marmoute added inline comments.
hgext/strip.py
1–47 ↗(On Diff #16914)

Why do we need that much code to remain into hgext/strip.py. What I would expect to see is a very small file that only register debugstrip as strip.

24–34 ↗(On Diff #16914)

What is going on here? IT seems like the same code with a different formatting.

pulkit added a subscriber: pulkit.Wed, Oct 9, 9:55 AM
pulkit added inline comments.
hgext/strip.py
3 ↗(On Diff #16914)

the documentation should be left as it is.

navaneeth.suresh retitled this revision from strip: move strip extension to core as debugstrip to debugstrip: add debugstrip to core.Sat, Oct 12, 5:59 PM
navaneeth.suresh updated this revision to Diff 17120.