Page MenuHomePhabricator

debuglock: rename flag names to better clarity
ClosedPublic

Authored by pulkit on Fri, Jan 8, 8:49 AM.

Details

Summary

--force-lock sounds as if we are taking the lock however in reality it's the
opposite.

Diff Detail

Repository
rHG Mercurial
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

pulkit created this revision.Fri, Jan 8, 8:49 AM
marmoute accepted this revision.Fri, Jan 8, 6:13 PM
marmoute added a subscriber: marmoute.

The current name are semantically correct, as "opening a lock without the key" is "forcing a lock". However I agree the new names are clearer in the context of Mercurial and for non-native speaker.

baymax updated this revision to Diff 24695.Sat, Jan 9, 8:03 AM

✅ refresh by Heptapod after a successful CI run (🐙 💚)

Alphare accepted this revision.Tue, Jan 12, 11:28 AM
Alphare added a subscriber: Alphare.

Agreed, this is clearer.

pulkit updated this revision to Diff 24777.Wed, Jan 13, 6:30 AM
This revision was not accepted when it landed; it landed in state Needs Review.
This revision was automatically updated to reflect the committed changes.